Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

For some reasons I'm having this error appears in my dashboard

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'admin_init' was given in /home/devromot/public_html/wp-includes/plugin.php on line 405

has anyone came across that before? if so do you know where problem might be?

share|improve this question
add comment

1 Answer

It seems you have a plug-in or theme activated which is trying to hook a function onto the admin_init hook, but the the function name they've given is not valid. Usually because the function doesn't exist, and potentially because they've put a space in the callback name.

Try deactivating your plug-ins/ themes one by one to identify which one it is. Then you'll just have to find the offending hooked function and work out why the name they've hooked onto admin_init invalid.

share|improve this answer
    
Brilliant, thanks Stephen for advice I will try to do that –  jmysona Jan 25 '12 at 12:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.