Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

H, I've installed wp on IIS7.5 machine. But I'm having error when my permalink setting is line: /%year%/%monthnum%/%day%/%postname%/

Problem is the index page (root page /) gives 404 error (EDIT: error is in a wordpress page, not server default page). But I'm not getting 404 when permalink is default or /index.php/%year%/%monthnum%/%day%/%postname%/

Site can be seen here: http://marmarabote.innovacube.com/

I've also rewrited urls in web.config like:

<?xml version="1.0"?>
    <configuration>
        <system.webServer>
            <rewrite>
                <rules>
                    <rule name="Main Rule" stopProcessing="true">
                        <match url=".*" />
                        <conditions logicalGrouping="MatchAll">
                            <add input="{REQUEST_FILENAME}" matchType="IsFile"
                            negate="true" />
                            <add input="{REQUEST_FILENAME}"
                            matchType="IsDirectory" negate="true" />
                        </conditions>
                        <action type="Rewrite" url="index.php" />
                    </rule>
                </rules>
            </rewrite>
        </system.webServer>
    </configuration>
share|improve this question
    
you seem to have solved it –  edelwater Nov 14 '10 at 0:35
    
@edelwater: no I haven't. I just use index.php as home url but this is not very good solution. Since I have an html page that redirects to index.php. –  Hasan Gürsoy Nov 25 '10 at 9:34

1 Answer 1

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.