Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I want to use the Google XML Sitemaps plugin and it says: "The plugin will not be active until you disable the multisite mode". I don't need a multisite mode.

share|improve this question
    
And I even don't how my blog came into multiside mode. Default I guess? –  waanders Jan 16 '12 at 13:41
add comment

2 Answers 2

up vote -1 down vote accepted

http://wordpress.org/support/topic/disabling-multisite-with-wp-30

http://www.bloggingjunkie.com/disable-multi-site-option-wordpress-30.html

share|improve this answer
1  
It's always nice to say a few words about the problem instead of just pasting links. –  vmassuchetto Jan 16 '12 at 13:10
1  
Lone link is considered a poor answer since it is meaningless by itself and target resource is not guaranteed to be alive in the future. Please try to include at least summary of information you are linking to. –  Rarst Jan 16 '12 at 13:12
    
I'm sorry for the mistake... I'll also add the summary from now onwards... –  gurudeb Jan 16 '12 at 16:52
    
I only changed define('WP_ALLOW_MULTISITE', true) in wp-config.php to define('WP_ALLOW_MULTISITE', false) and the Google XML Sitemaps plugin is satisfied. Still don't know how this line came into my wp-config.php file –  waanders Jan 17 '12 at 10:59
add comment

You need to do three things (after backing up your database, of course).

  1. Take out the multisite lines from wp-config.php. In my site, it was three lines referring to multiple domains and multiple sites.
  2. Get rid of the multisite .htaccess. For this, you can either put back the old single-site .htaccess or empty it out. Either option will work.
  3. Remove the multisite database tables:

    • wp_blogs
    • wp_blog_versions
    • wp_registration_log
    • wp_signups
    • wp_site
    • wp_sitemeta
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.