Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I design my site in win7 system, and today before a server rent, I moving my blog from win7 to my another computer witch is installed CentOS 5.5 for a last test, I have reference the article http://codex.wordpress.org/Moving_WordPress

moving my site from d:/www/ to /var/www/html, and my site runs well, all the post, comment have no problem.

But I can not login into my site. I have two test accounts, one is admin, another is normal user, both account can not login into. when I fill with the username and password, click login button, then page will refresh and do nothing still return to the login page with no error hint. I searched google with a ton of posts, I have tried to rename the plugin folder, clear the web browser's cookies...

Sorry for I can not test a password forget and register, because I have't install any mail scripts in localhost.

Waiting for a possible solution, regards.

share|improve this question
    
Are you using WAMP, XAMP, or something else? –  Jeremy Jared Jan 11 '12 at 0:40
    
@Jeremy Jared, in windows I use WAMP. but in CentOS, i install mysql, php via yum from mysql and php official downloads tar.gz package. then input full wordpress database, change wp_options site url and home to new, so my site's other links all runs well. but just the login issue... I can not login into admin panel to rebuilt permelink for a new .htaccss –  cj333 Jan 11 '12 at 14:00
add comment

2 Answers 2

up vote 1 down vote accepted

I have solved this strange problem by myself. Share my experience to all.

Find these 2 lines in /etc/php.ini

upload_max_filesize 16M 

post_max_size 16M

Add common before, so that change as:

;upload_max_filesize 16M 

;post_max_size 16M

And final, do not forget restart apache: service httpd restart via SSH.

Then I could login into my site under linux as the win7 system.

share|improve this answer
    
I really don't see ANY relation at all between these PHP settings and a login page not working - ordinary a password reset delivered to a local mailbox should have done the trick. If it really fixed it, something must be messed up with your PHP installation/configuration. –  syslogic Aug 17 '12 at 1:18
    
Having similar problem and this did nothing for me. –  8None1 May 7 at 18:44
add comment

I think that you may need to modify some data in your database.

Assuming your table prefix is wp_ and your database is wordpress...

1) Open up the database Admin

2) Look under the wp_options table and look for siteurl verify it is correct.

3) If you have multisite, look under each wp_XX_options and verify the siteurl is correct.

4) Head to the login page... and login

5) Problem Solved. (hopefully)

share|improve this answer
    
hi, I have only one site, build width wp3.2 and buddypress. I have changed the wp_options, siteurl and home to new, so my site's other links all runs well. but just the login issue... –  cj333 Jan 11 '12 at 13:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.