Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I just installed WP Super Cache plugin and enabled all settings which were suggested by this plugin. After doing it I am seeing a warning.

Warning! PHP safe mode enabled!

What is this? What should I do? How will it effect my blog?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

What is this?

Safe mode was an attempt to solve shared-server security problems at the PHP level. It restricts and even disables some built-in PHP functions (e.g. mail(), header() and session_start() -- see attempted full listing of functions restricted/disabled in safe mode)

What should I do?

If you have access to your PHP configuration file (php.ini or php.conf), you can disable safe mode by searching for safe_mode and setting it to 0. If you're not sure where your PHP configuration file is, create a new PHP script called info.php with the following code in it

<?php
phpinfo();
?>

upload it and then access it via your browser. Look for the value to the right of "Loaded Configuration File", which will be the location and name of the configuration file you must edit. See the list of related security directives and their default values which you can restore as well if you're still getting a warning message.

If you don't have access to your configuration file or can't make these changes yourself, you will need to ask your host to do it for you. Safe mode has been deprecated as of PHP v5.3.0, so it's likely they're running an old(er) version of PHP.

How will it effect affect my blog?

It shouldn't affect your blog in any way, I suspect you've only become aware of it because Super Cache specifically checks for that setting and then warns you if it's on. Technically, it's just a warning, so unless if has completely halted the functioning of the plugin itself, you can ignore it. However, since safe mode is now deprecated you should set it to off or have your host do it for you.

share|improve this answer
1  
Thanks for the great explanation. I made info.php and came to know that safe mode is ON. I contacted my hosting company and they denied to made any changes in that file. –  Chankey Pathak Jan 6 '12 at 11:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.