Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Basically going mad on this one. Been googling about for quite some time now to find an answer. Most hits are on year old posts. I tried to alter how TinyMCE initiates with "remove_linebreaks" set to false in functions.php.

The thing is altering text, at least this little group of three paragraphs in two td-cells in a table.

  1. At first I alter the HTML to my liking and save. (This error occurs with or without the MCE Table Buttons plugin, so you need not worry about me having forgot to turn that off.)

New user can't post image so description is: two equal sized td-cells with three paragraphs each, with some internal line breaks as well.

  1. Everything is at first all fine. But when I do some, or no, edits and save again this screen meets me. The first paragraph in each td-cell is joined with the second paragraph. This mating removes the seperating spaces all together.

New user can't post image so description is: Same cells and sizes, just that the first paragraph and the second merged, removing all separating spaces between them (end of p1 is on the same line as start of old p2). Paragraph 3 is unaffected.

  1. When I save a third time the first paragraph again mates with the second (thus only one paragraph exists in both cells). Ofc this looks very ugly, and this is very hard to explain to the client (they do have zero html-understanding).

New user can't post image so description is: Now all paragraphs has become one, with end of old p2 being on the same line as the start of old p3.

  1. After the save on step 3 in admin this is shown on the frontend. This means that the html must get broken on hitting save, or while loading it into the editor AND on the page.

*New user can't post image so description is: It looks exactly as in the admin.

Been digging around some in autop, but that's beyond my php-skills. Anybody else known to this -- as it looks -- very common problem?

I use Wordpress 3.3, haven't tested in any other version. Any suggestions?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

This error was corrected when I installed the plugin TinyMCE Advanced and activated the option "Stop removing the <p> and <br /> tags when saving ...".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.