Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a weird issue after upgrading to WP 3.3. Currenty I have a Dreamhost dedicated server with WP 3.2. I've tried two times to upgrade to WP 3.3 and both times I had the same issue.

First time, I tried to upgrade directly from the admin panel. Everything seems to be OK but all the updates against the DB perform errors. Let say, I tried to write a new post and nothing was saved. I tried to change some options in a plugin a a message is displayed "Are you sure you want to to this?" without any button to continue...

After a fresh installation of WP3.2, I get restore the content tables (not the wp_option) and everything works fine again.

Few days ago I tried again to upgrade, but this time from console. I uncompress the wp zip file and in the instalation directory and then entered in the admin panel. A message saying some upgrade in the DB appeared. After pressing OK button, seems everything works fine until I tried again to publish something... The issue of posts disapearing happened again. Also, this time on every page change, the message "The DB needs to be upgrade" appeared again, but no these times, no change were needed.

Everything seems too weird for me. And also, WP does not provides any log or information about what is happening. Could anyone help?

Thanks a lot.

Alberto

share|improve this question

2 Answers 2

Try working through the solutions listed in: Troubleshooting WordPress 3.3 - Master List

share|improve this answer
up vote 0 down vote accepted

Finally I found the problem. I was using the Cloudflare service. Something in the acceleration technology they are using does not works well with WP 3.3. I've disconected the service and everything works fine. Just warn everyone.

Regards

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.