WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a blog on shiplu.mokadd.im. After installing wordpress I see upgrade notice time to time. Sometimes its core upgrade and sometimes its plugin or theme upgrade. Each time I try to upgade any of them I see wordpress asks for ftp credential. To resolve this I have created ftp account. But somehow wordpress fails to log in.

My question is how can I make this upgrade working directly from dashboard? If its an ftp account what type of privileges would it require? If its ch{mod,own}, what is the secure way?

I am using version 3.2.1

share|improve this question

migrated from superuser.com Dec 19 '11 at 8:17

This question came from our site for computer enthusiasts and power users.

How did you install WordPress? Which version are you running? – iglvzx Dec 19 '11 at 7:03
Its 3.2.1. Also added in the main question now. – Shiplu Dec 19 '11 at 7:10
It should automatically be upgradable. Do you have a Dashboard > Upgrade option? What is your main wp-content directory chmod too? – BandonRandon Dec 19 '11 at 9:50
its drwxr-xr-x 5 root root 4.0K 2011-12-18 23:36 shiplu.mokadd.im – Shiplu Dec 19 '11 at 13:13

This is an issue with your server configuration, not with WordPress. Generally, it means that the server is not configured to use suPHP. (More, via Otto, here and here.)

The (usually simple) solution is to add your FTP information to wp-config.php:

define('FTP_USER', 'username');
define('FTP_PASS', 'password');
define('FTP_HOST', 'ftp.example.org');

Put these in wp-config.php (with your specific information, of course), and you should no longer see the FTP credentials screen.

share|improve this answer

If FTP fails with the domain name and "localhost", make sure you have FTP configured to allow connections via the loopback connection as well.

If you don't want to use FTP credentials, configure your server to use setuid methods for running PHP processes. How to do this depends on your specific server configuration. On many linux systems, suPHP is the easiest, albeit not the most efficient, way.

share|improve this answer
up vote 0 down vote accepted

I have solved this problem by changing the owner of the wordpress directory to www-data.

chmod -R www-data:www-data /path/to/wordpress/on/apache/
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.