Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have set my blog permalink as follows:

/news/%postname%

This works. Going to any post, such as /news/test, will serve the single.php as expected. I can also browse to a category such as /news/category/uncategorized, which brings up the archive.php. All good.

However, when I browse to /news (which I was expecting to also bring up archive.php) I get a 404 and I don't understand why? I was at least expecting to be served the index.php not a 404.

Ideally I have the archive.php template served by browsing to /news but to solve the 404 issue first would be great.

Any suggestions much appreciated.

PS: I was hoping to prevent to create a dummy /news page.

PPS: Yes, I always clear my permalinks by saving them from the Settings panel.

share|improve this question
add comment

1 Answer

if you're trying to make the news serve as a homepage you should use the Site address (URL) in the WordPress general setting options.

and of course you'll getting an 404 error page since the news/ in your permalink serve as a directory which is refer to your server directory that not connected with the WordPress itself. try to create a news directory in your public_html and add some index page to see what happen.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.