Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have several CMS websites using TinyMCE Advanced plugin and the editor-style.css style sheet to make editor text resemble website text. After updating to WP 3.3, the editor no longer uses the stylesheet on any of the sites.

This might not be a WP 3.3 problem: once I updated WP, TinyMCE Advanced showed that it needed to be updated, so updated that. The problem could very well be with the latest version of TinyMCE Advanced.

Any clues about why or how to fix?

Although I still don't know if the problem is with WP 3.3 or TinyMCE Advanced (I suspect the latter), the following function in my functions.php file enables the editor stylesheet:

// Add custom stylesheet to TinyMCE editor
if ( ! function_exists('tdav_css') ) {
    function tdav_css($wp) {
    $wp .= ',' . get_bloginfo('stylesheet_directory') . '/editor-style.css';
        return $wp;
    }
}
add_filter( 'mce_css', 'tdav_css' );

Problem solved.

share|improve this question
2  
Try disabling the plugin once and see if you get the expected behavior. If yes, then the plugin is doing it else WordPress, if only these two have changed since the last time they were working. –  Ashfame Dec 16 '11 at 0:15
    
Good thought, but I'm not sure it's that simple, since TinyMCE Advanced is what enables the stylesheet when placed in the theme folder. So of course, with the plugin activated, the stylesheet also does not style the editor content. –  Ray Gulick Dec 16 '11 at 15:40
    
Guess I will add a function in my functions file to enable the editor stylesheet. –  Ray Gulick Dec 16 '11 at 15:46
    
add_editor_style(), combined with editor-style.css, is your friend here. :) While I'm sure there are other, valid reasons for using TinyMCE Advanced Plugin, styling the editor to match the front end is not one of them. WordPress core handles it by default (though it must be supported on a per-Theme basis). –  Chip Bennett Dec 16 '11 at 16:44

1 Answer 1

up vote 0 down vote accepted

Solution : Step 1 : Change the theme Step 2 : Clear the cache Step 3 : Go to your editor Step 4 : Change to 'HTML' Step 5 : Change to " Visual Editor' Step 6 : Now you can find the Visual Editor Options Step 7 : Change to your original theme

If Problem Persists, Add ' WP-Super Edit / Use Google Library ' Plugins, then check it. :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.