Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm running wordpress multisite, and when I connect to my domain at domain.com I get the error "Greetings Site Administrator! You are currently allowing “none” registrations. To change or disable registration go to your Options page."

Should I create a 301 redirect from non www to www.domain.com or is there a way to configure multisite to handle this redirect?

Thanks

share|improve this question

3 Answers 3

you can make that happen in the .htaccess file. just add these lines:

RewriteEngine On
RewriteCond %{HTTP_HOST} ^domain.com
RewriteRule (.*) http://www.domain.com/$1 [R=301,L]

this will do a 301 from non-www to www of your domain.

share|improve this answer

You could try using the WPMU domain mapping tool to map the base domain to www.domain.com:

http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

share|improve this answer

Rather than rely on a plugin or modify your .htaccess file ... the best permanent fix is to login to your Domain Registry and make sure you have both the www and the . records setup.

This means that the DNS will handle your www and .domain requests and you don't have to worry about that .

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.