Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Hi I am having a problem, I updated my wordpress site to version 3.3 and the site itself seems to be working fine except I cant log into the dashboard anymore.

When I login using my admin details it keeps re-directing me to /forums/profile page for admin user. Please can anyone help me out or has anyone came across this problem before?

Thanks Louise enter image description here

share|improve this question
    
If you are using any dashboard related plugins, it may be conflicting with the new setup. Try disabling all your plugins (by temporarily renaming the files in your wp-content/plugins folder) and try accessing. –  Sterex Dec 14 '11 at 11:22
    
Also, it will help if you can provide a screenshot or tell us the exact error that you are encountering, we will be able to provide a better solution. :) –  Sterex Dec 14 '11 at 11:24
    
Hi Thankyou for the advice, I changed the name of the simple-forum plugin and it let me have access a panel like the image above, however this is not full admin access, where are the menu's to the left? None of the other plugins had any change only this one, Any help would be appreciated thanks –  Louise McComiskey Dec 14 '11 at 11:55
    
It is as if I dont have full access anymore because when I try and go to /update-core.php or /tools.php etc, I get a "you have insufficient priveleges" error –  Louise McComiskey Dec 14 '11 at 12:10
add comment

migrated from stackoverflow.com Dec 14 '11 at 16:51

This question came from our site for professional and enthusiast programmers.

2 Answers

up vote 1 down vote accepted

Okay, seems like the user permissions got changed. Did you have a plugin that manages user roles?

Anyhow, I'm assuming that you have database access. Check the role that has been assigned to the user.

You may have to change this manually to an administrator by editing the database.

Hope this helps. :)

share|improve this answer
    
Do you have any idea of how to manually change to an administrator in the database? –  Louise McComiskey Dec 14 '11 at 14:22
    
Sorry, I assumed you would know how to. Please follow @Kash's answer :) Hope your ordeal is solved. :) –  Sterex Dec 15 '11 at 5:08
add comment

If you have access to phpMyAdmin, you can reset user permission from database. But first thing first, t proper ake backup of your wordpress database.

In phpMyAdmin, locate your wordpress database and find table called wp_usermeta. There is a setting for your admin user's priviledges. You will find a field that contains something like:

a:1:{s:6:"author";b:1;}

You must change it to:

a:1:{s:13:"administrator";b:1;}

After saving your changes in phpMyAdmin, now try to login to worpdress dashboard.

Another and better solution is to create a new user with admin privillege via phpMyAdmin and then change your original user role from Wordpress Admin Dashboard. Here is a nice guide for you. I would recommend you to go this way.

If you are not comfortable doing this, please ask your webhost if they can do this for you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.