Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am developing a site on MAMP and everything is going fine except that I thought I would check how all the default archive pages look. I typed 2011 at the end of the base url and it retrieved a yearly archive as expected.

The problem is that the font sizes of every element change to a smaller size. I understand that there are different headings in the archives, but this problem affects the main nave menu, normal li items ... everything.

Has anyone had this happen to them?

Thank you.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Use your browser’s debugger to find the applied CSS rules. Usually there are some some unclosed elements and/or some badly written CSS rules like #content * { font-size: .9em }.
It’s not a WordPress problem. :)

share|improve this answer
    
Thank you for the quick reply and for the reminder to do what I always tell my friends to do - check everything. It ended up being a duplicate class date that had a font size set and when the archive page set the body class to <body class="archive date"> it grabbed that font size and since the sizes were in ems the mistake cascaded through the page. Working now. –  John Bentwin Dec 9 '11 at 2:05

Look at your archives.php template file and see what CSS and HTML is involved, and use Firebug with Firefox, or in Chrome or Safari or IE8, use the developer tools to see the active CSS and HTML.

share|improve this answer
    
As I said above, thank you for reminding me to check everything. I also validated my CSS in the process. –  John Bentwin Dec 9 '11 at 2:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.