Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am using wordpress Version 2.9.2 and XML Sitemap Generator 3.2.3

I have registered with Google Webmaster Tools.

But I get an error while notifying to Google and I really don't know what it means.

Heres a screenshot :

alt text

And when I click on view result it show me the following message:

Ping Test

Trying to ping: http://www.google.com/webmasters/sitemaps/ping?sitemap=http%3A%2F%2Fsearock.bplaced.net%2Fsitemap.xml.gz. The sections below should give you an idea whats going on.
Errors, Warnings, Notices:
WP_DEBUG was set to false somewhere before. You might not see all debug information until you remove this declaration!
Result (text only):
Result (HTML):

If I want to debug the error where can I find WP_DEBUG ? Can someone tell me what's wrong here.

Note : I have completed Google Webmaster verification process.

Thanks.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

WP_DEBUG is a constant which you can define in wp-config.php to disable hiding of PHP errors and notices.

Add define('WP_DEBUG', true); to your config file to enable it.

Just remember to never leave it on for long on a live blog.

Since all pings fail this is likely not an issue with specific sitemap service, but with ping process itself. I think it might be HTTP requests failing for some reason, but there is no way to tell definitively from information you provided so far.

share|improve this answer
    
+1 what additional details do you need ? Do you want the error message after setting WP_DEBUG to true? –  Searock Nov 4 '10 at 17:54
    
@Searock yep, that would make sense for starters. Also if this is HTTP-related you can try Core Control plugin that has great functionality for testing and logging HTTP requests in WP. –  Rarst Nov 4 '10 at 20:00
add comment

Try to Check your .htacces, and reset to wordpress default .htaccess;

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

and go to plugin to REBUILD Your Sitemap manually...., well at least IT WORKS FOR ME... !

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.