Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I recently migrated a WordPress install from a subdirectory to the root. After the migration everything worked great, except that I can no longer set a featured thumbnail or add a picture in the WYSIWYG. On a possibly related note, I can only set post tags from the Quick Edit screen and not the post edit screen.

When I click set featured image on the post edit screen it opens the screen to add media, but it opens in a new page, not like in a box before. When I click to the media library and click show next to an image, it does not show and so I can't select "use as featured image." I can still upload the photo, but I can't attach it to the post.

I'm not sure if the tags issue is related, but whenever I enter a tag in the Post Tag box it will not save. But if I go out to the All Posts listing, I can enter them via Quick Edit.

Any ideas? Thanks in advance.

share|improve this question
    
Could be javascript errors. Do you have any js errors showing up in firebug console? –  patnz Dec 7 '11 at 23:12

2 Answers 2

  1. check your media upload path in the admin.
  2. verify that your DB has NO references to the old domain (I am sure you have done so already, but I will post it anyhow) when you do that , include the last trailing slash.

// update WordPress options , SQL command:

  UPDATE wp_options SET option_value = replace(option_value, 'http://www.old-domain.com', 'http://www.new-domain.com') WHERE option_name = 'home' OR option_name = 'siteurl';

// fix URLs of the WordPress posts and pages, SQL query:

UPDATE wp_posts SET guid = replace(guid, 'http://www.old-domain.com','http://www.new-domain.com');

// SQL commands to fix all internal links

UPDATE wp_posts SET post_content = replace(post_content, 'http://www.old-domain.com', 'http://www.new-domain.com');
  1. if that is not helping, disable all plugins (and custom function - functions.php) , remove all custom JS files, and try again .
share|improve this answer
up vote 0 down vote accepted

I figured it out. It was a jQuery conflict. I deregistered the default jQuery in WordPress to use the Google CDN version. Works great on the front-end, but it was messing up the admin. Wrapped it in an !is_admin() if statement and all is well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.