Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I installed the plugin and assigned it to the relevant page but the problem is that the custom fields display 'no image selected' after I have uploaded them and do not appear on the relevant page. Any ideas?

For reference, I have set 'Page Template' as equal to 'Home' (the relevant page) on the custom fields rules.

This is the code I am using to call the image on the template:

<img src="<? the_field ('image_2'); ?>" class="middle" alt="image2"/>
share|improve this question
    
You're missing the php after the question mark at the beginning. That might be the only problem. –  Christopher Dec 3 '11 at 21:22
    
Thanks, that definitely needed to be added but it is still not linking. –  tobeeornot Dec 4 '11 at 12:48

1 Answer 1

up vote 0 down vote accepted

Did you use the correct format in Advanced Custom Fields when you set up the field?

It has an option to return the attachment ID or the image URL when you create the field. So to use it this way you'd have to be sure that it was outputting the image URL not the attachment ID.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.