Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I tried to install Gallery 3 as a subdirectory in my WordPress folder and point a subdomain to it, but it doesn't work. The gallery site comes up initially, but there is no theming to it and if I try to click on login I get a 404. The URL that comes up when I click log in ends with "/index.php/login/ajax" which doesn't seem right. Anyone else try to do this?

Thanks in advance!

share|improve this question
add comment

1 Answer

Your problem is that you installed it in a subdirectory of WordPress. Both WordPress and Gallery 3 will use virtual URLs in their domain, and with them both acting on the same folders, neither system knows what to do.

So you have http://blog.url/ and http://blog.url/gallery3/ which is also http://g3.blog.url/.

The subdomain will point to that folder without any problem ... http://g3.blog.url/ will redirect to http://blog.url/gallery3/ ... but http://g3.blog.url/something will redirect to http://blog.url/gallery3/something.

Logically, you'll think this will work, but both Gallery 3 and WordPress will try to eat this URL to pass it to the appropriate page. WordPress will send http://g3.blog.url/login/ajax to http://blog.url/index.php/login/ajax because that's where it thinks you're trying to go.

My recommendation would be to not use a subfolder of the WordPress directory for Gallery 3. Put it in a separate folder altogether and point your subdomain there. Then tell WordPress to reference the subdomain rather than the subfolder. You won't run into .htaccess collisions that way.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.