Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

What are the possible causes for getting the "You do not have sufficient permissions to access this page." message when logged in as admin? I've done a lot of searching and found a lot of possible solutions, but in my case they haven't worked.

In my case I've taken a copy of a database off our staging site (close enough to having the same code) and placed it on dev, done the usual steps of changing values in the options table, gone to the lengths of disabling all plugins (through the database, even to the point of renaming the plugins folder). It was a multisite install at one stage (but this should have been cleaned up). I can log in, but get the access denied when I try and go to the dashboard page.

share|improve this question
    
The main purpose of this question is to build up a bit of a repository of possible reasons for the access denied error (as admin, aka user 1). While I have a specific problem (and the one that solves this will get the accepted answer), it is more so that others that google the issue can see a list of possible solutions to their problem (which may or may not be the same as mine). –  Brian Barnes Dec 1 '11 at 20:48
add comment

2 Answers 2

Yes this happens either there is no proper permission or you might placed wrong argument for custom post or meta box.

Could you please elaborate so that I can spot it out where exactly the problem, assuming that you are created custom post type or custom meta box with wrong arguments.

share|improve this answer
    
That doesn't make sense to me - as mentioned in the question I've disabled all plugins (so it shouldn't be a problem with custom post types - but I'll look into that just in case). –  Brian Barnes Dec 1 '11 at 20:41
add comment
up vote 1 down vote accepted

In my case it happend that the capability for user 1 somehow got wiped, so the SQL command: INSERT INTO wp_usermeta (user_id, meta_key, meta_value) VALUES(1,"wp_capabilities",'a:1:{s:13:"administrator";b:1;}'); did the trick.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.