Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I added template to my WP posts, so when you click Add New content area alreday with text. Template smt. like this

<div id="myDiv"><p>Add your text here</p></div>

If user has Admin or Editor roles then it works great, but if user has Author role id sprips, and I got

<div><p>Add your text here</p></div>
share|improve this question
    
It's not clear what the problem is, and you've posted no code for us to look at, until you do there's nothign we can do to help. If you could post the code that generates that markup and provide a little more context? –  Tom J Nowell Nov 23 '11 at 13:06
    
It's standard WP, I don't know what code I need to post, because can't find where is the problem... Probably this is not the problem, just WP specific. If you try to login like author, then go to adding post, insert onto HTML editor something like this '<div id="test"><b>sdasd</b></div>' you will se the problem 'id="test"' will be stripped. –  Narek Nov 23 '11 at 13:23
    
Please let me know if some parts not clear. –  Narek Nov 23 '11 at 13:27

1 Answer 1

up vote 0 down vote accepted

WP stripts HTML for authors. I had this problem too. I'm sure this post can help you. How can HTML be allowed in Author Bio? or this: https://wordpress.org/support/topic/authors-can-not-embed-video#post-1483017

share|improve this answer
    
Thank you very much! This helped me a lot! –  Narek Nov 23 '11 at 15:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.