Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've just created a new WordPress multisite install and am having an issue with custom permalinks (the standard 'Day and Name' option) to the pages for the main site. I'm using the standard config presented when configuring a network (see SubFolder Example here) and have my .htaccess set to mod 666 (writable by all).

I currently have one sub-site configured which creates a 'Sample Page' page. This link works fine, but the link to an 'About' page I've created for the main site just re-displays the main page.

Here's the .htaccess file I'm using:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# uploaded files
RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
RewriteRule . index.php [L]

What can I do to get this working?

share|improve this question

migrated from stackoverflow.com Nov 22 '11 at 15:56

This question came from our site for professional and enthusiast programmers.

    
I wasn't able to determine exactly what the issue was, but since this was a new install I just scraped it and started over. The new site worked perfectly, so I'm going to assume I screwed up some settings the first time somewhere along the way. –  Derek Greer Nov 23 '11 at 22:05

1 Answer 1

Check your httpd.conf file. Sometimes Apache's settings can be too restrictive and it doesn't quite catch all the rewrite rules.

Look for Allow FileInfo Options for that vhost. Might have to set it to All. I explain this here: http://wpmututorials.com/installation2/subfolder-blog-have-no-theme-styles/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.