Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm trying to upload my plugin for the first time to the WordPress SVN. I've been granted access from the WordPress team. I am able to download the directory. Then I try to place my plugin files into the trunk folder, and then commit the changes. When I do this. I am prompted for my login credentials. I use the same ones that I use on the Wordpress.org website. However, it keeps re-prompting me to enter my credentials.

I am not sure what I am doing wrong. I made a screencast of the process.

http://www.screencast.com/t/3QCfSdyM

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

Try changing your password @ wordpress.org then retry.

If still fails check your firewall log

If it still fails ... ask Andrew Nacin :) http://twitter.com/#!/blamenacin :)

share|improve this answer
    
Funny, I tried this right before I saw your response. Didn't work though :( –  mikemick Nov 1 '10 at 14:15
    
It might be a firewall issue. I'm in a corporate setting, and there are all kinds of restrictions on everything. I'll try it in a different environment later on, and report back. Thanks. –  mikemick Nov 1 '10 at 14:17
1  
I changed it to "https" based on your Firewall comment, and it now works. Yippee!! –  mikemick Nov 1 '10 at 14:23
add comment

I've had issues with this as well, and my solution was to use a different form of the plug-in repository URL.

They give you: http://plugins.svn.wordpress.org/PLUGIN-NAME

With Tortoise SVN I've successfully used: http://svn.wp-plugins.org/PLUGIN-NAME

Give that a try and see if it helps.

share|improve this answer
    
Same situation. However, that is a nice tidbit to know. Thanks. –  mikemick Oct 29 '10 at 15:57
add comment

Try clicking the "Save authentication" checkbox...? I had an issue like that, and if I wasn't saving the authentication, I would have to reenter password before every single command or transfer.

share|improve this answer
    
Yup, I've done that. Same thing. –  mikemick Oct 29 '10 at 17:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.