WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have made my Front Page as a Static Page. The Page is having a Introduction Content. I am showing this content as an introduction to the site. But it displays "Leave a Reply" Box below it. I do not want the users to give comments on this content. Can somebody suggest How to suppress this for my Static Home Page for all users except Admin.

share|improve this question
show us the code you are using so I can tell you :) – andresmijares25 Nov 19 '11 at 16:40
up vote 3 down vote accepted

Follow these steps:

  1. Go to 'Pages'.
  2. Look for the page you've set as your homepage in the list.
  3. Hover your cursor over the title and click on 'Quick Edit'.
  4. Uncheck 'Allow Comments' and then 'Update'.

Edit: For disabling Trackbacks and Pingbacks (and Comments too!):

  1. Open the page you've set as your homepage for editing.
  2. Look for a box titled 'Discussion', and uncheck 'Allow Pingbacks and Trackbacks on this page'.
  3. If the 'Discussion' box is not visible on the edit page, then click on the 'Screen Options' button which is at the very top (near 'Howdy Admin'). Select 'Discussion' from the panel.
  4. Now repeat step 2.

Hope this helps! If it's not clear, please let me know, I'll put a screen shot.

share|improve this answer
It now says "Comments are closed, but trackbacks and pingbacks are open" I just wanted it to look like a Introductory Text" without anything showing below it. – sushil bharwani Nov 19 '11 at 16:47
Okay... Editing my answer... – Rutwick Gangurde Nov 19 '11 at 16:49
Please check my original answer again. – Rutwick Gangurde Nov 19 '11 at 17:00
Thanks Buddy .. Nice Help – sushil bharwani Nov 19 '11 at 17:09
You're welcome my friend! – Rutwick Gangurde Nov 19 '11 at 17:13

protected by toscho Nov 28 '12 at 7:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.