Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I had to move my solution from one server to another. I therefore Exported all data so that I could import this on the new server.

All worked fine except users.

If I want to edit my own profile, all is well.
But if I try to edit another user profile, I get these error messages:

Notice: Undefined property: WP_User::$rich_editing in I:\Development\wamp\www\storelocator\wp-admin\user-edit.php on line 199

and

Notice: Undefined property: WP_User::$nickname in I:\Development\wamp\www\storelocator\wp-admin\user-edit.php on line 285

After I imported data from the other server, all nicknames have this text:
<br /><font size='1'><table class='xdebug-error' dir='ltr' border='1' cellspacing='0' cellpadding='1'><tr><th align='left' bgcolor='#f57900' colspan=

If I click Update, data is stored and the error messages goes away.

What could be the cause of this?

share|improve this question

1 Answer 1

One of the reasons could be that while exporting/importing the data the server debug or 'WP_DEBUG' must have been true for warnings/errors. Hence they must have cropped up in the export file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.