Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

So I recently moved my site to a new server, and now some of my plugins will show only if you are logged in as admin, but will not show to the regular user. However, some plugins still show and work fine. I have already reinstalled and that hasn't done anything. Any ideas?

Thanks!

share|improve this question
    
Add more information describing the exact behavior of widgets and did you move the database too? Very likely not. –  Ashfame Nov 11 '11 at 9:58
    
Well one of the plugins is the Gigs Calendar plugin, and it displays all Gigs posted before I moved the website, but now if I add any more only I can see them if I am logged in as admin. Another one is that if I can only see a facebook like plugin if I am logged in as admin. And it is essentially the same issue with several other plugins. I did move the databases also, but I don't think that they are the issue because when I add a new gig it shows up in the database, it's almost like it's some kind of weird permissions error where only the admin sees these plugins.. –  srchulo Nov 11 '11 at 10:08
    
Well the plugin can't misbehave on the working aspect of a user's role as such unless it its designed to. Its something else, but current information doesn't ring any bell. Sorry! –  Ashfame Nov 11 '11 at 11:12

1 Answer 1

up vote 0 down vote accepted

I found the issue. The problem was that there were two plugins I was using (A facebook likebox and a twitter plugin) and apparently these plugins are pretty well known to break other plugins on the site if they are installed. I removed those to plugins and then the rest of my plugins all started working fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.