Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I manually installed wordpress on my server and the wordpress files are located in "www.mydomain.com/wordpress/", however I wanted my "www.mydomain.com" to be the address for my wordpress blog instead of "www.mydomain.com/wordpress/" so I went to the "Settings->General" screen in my dashboard and changed the "Home" url to "www.mydomain.com/wordpress" and the "Site" url to "www.mydomain.com" thinking it would make my home address the blog address. When I went back to the admin page I get a "Not Found (404)" error message and all the CSS formatting is gone from my blog.

Is there a way to reset my settings?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

If you've got access to the database (via phpMyAdmin or the like) you can change those two values in the wp_options table. Look for siteurl and home in the option_name column.

share|improve this answer
    
Thank you! I was going crazy over the whole affair. –  user701510 Nov 9 '11 at 6:49
add comment

You can override the database setting in wp-config.php

define( 'WP_HOME', 'http://example.org' );  //<------This is what you want users to type into their browser to reach your site.
define( 'WP_SITEURL', 'http://example.org/wordpress' );  //<-------- This is where Wordpress is installed.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.