Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Using IIS 6 on XP Server '03, using WP 3.2.1, when I attempt to use the auto-update for my plugins, I receive this message:

The update process is starting. This process may take a while on some hosts, so please be patient.

Enabling Maintenance mode…

Updating Plugin [Plugin Name] (1/1) Downloading update from http://downloads.wordpress.org/plugin/polldaddy.2.0.10.zip

Unpacking the update…
Installing the latest version…
Removing the old version of the plugin…
Plugin update failed.
An error occurred while updating [Plugin Name]: Could not create directory.
C:/Inetpub/wwwroot/wp-content/plugins/polldaddy/

Disabling Maintenance mode…

All updates have been completed.

When I go to delete a plugin through the WP interface, it removes the plugin from the "Installed Plugins" list; however, when I navigate to the directory on the server, I still see the plugin folder in the wp-content folder and I can't open it or delete it. Says, "Access is denied".

I don't have any troubles installing new plugins via the WP "Install Plugins" web interface.

I've set the IUSR & IIS_WPG accounts with full control on the wp-content folder and it cascades the permissions down to the other folders. So when I update, it should have the rights to remove/update plugin files.

The weirdest thing to me is if I restart IIS (iisreset), I'm able to auto-update via the web interface just fine & I am then able to delete the "removed" plugin folder that said "Access is denied".

This is frustrating as I don't have time to always stop what I'm doing to reset IIS & wait on it to start back up again.

Any ideas?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

I had the same problem. When auto-updating, certain files would get "locked" somehow stopping the rest of the update process.

Are you using Windows cache extension for PHP by any chance?

Read the following post: http://ruslany.net/2011/04/wincache-and-wordpress-plugin-upgrade-problem/

share|improve this answer
    
Apparently I am. I checked my WPI and it says WinCache Ext 1.1 for php5.2 is installed. Thanks for the link. –  joshmax Nov 7 '11 at 19:40
    
no problem - this bug drove me nuts before I as able to pinpoint the cause. –  Bundarr Nov 7 '11 at 19:56
    
WPI installed it for me originally, so I'm not sure where to extract the files to now. –  joshmax Nov 7 '11 at 21:28
    
thanks! I'll have to wait until the next plugin needs updating, but I'm pretty sure it's fixed. I was able to delete a plugin without a problem. –  joshmax Nov 8 '11 at 21:37
    
Your answer resulted in a big win for me with the execs! Thanks! –  Bradley Mountford Mar 13 '13 at 20:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.