Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

My WordPress blog is hosted on a shared webserver on Hostgator. I've been having 500 Internal Server Errors the last couple of days. I haven't installed any new plugins since the errors started showing up.

I contacted tech support a few times but never got a succesful answer. The webhost has a process limit of 25. At times the process limit is reached, so the websites on that server go down. When looking at the process console, I see the process that's been spawning a lot is php serving the index.php file of my blog.

When I first contacted support, they told me it could be due to a large traffic increase on my site. But I have no reasons to think the traffic might have increased that much in a day. Checking Analytics (although most request must be getting lost due to the errors), I notice there hasn't been any important increase on traffic. Besides the site has been through some "Slashdot effects" before going to four or five times the daily hits average without any issues.

Another support guy told me to switch the WP-Super Cache plugin for W3 Total Cache, since that's the one Hostgator recommends. This didn't change anything either. I tried deactivating and uninstalling both, then checking with Hyper Cache, and I never found different results.

When changing WP-DEBUG to true, all I see are some warnings from All In One Seo Pack and this other plugin.

All of the tech supports told me there was a plugin that was causing this. So I disabled them all and started trying and enabling one by one. The thing is, I still haven't been able to figure out which plugin (if that's the issue) is causing the trouble. In conclusion, they haven't been of much help.

What are my options to debug and find out where the problem is? EDIT: My active plugins: Akismet, All In One SEO Pack, Dagon Design Sitemap Generator, FastFast Secure Contact Form, Google XML Sitemaps, Laconica Tools, List Category Posts, NextGEN Gallery, RubyConf Uruguay Ribbon, Smooth Slider, Subpage Listing, Subscribe to Comments Reloaded, UserAgent Spy, W3 Total Cache, WP-PageNavi, WP-Syntax.

share|improve this question
    
Had the same issue, but unfortunately I couldn't find the reason either. Ultimately the support guys killed all the processes and this never happened again since. –  onetrickpony Nov 3 '11 at 0:53
    
Have you tried increasing the php memory limit? –  Brad Dalton Nov 3 '11 at 12:04
    
This question is bordering on being too localized, but can you list all of your active Plugins? –  Chip Bennett Nov 3 '11 at 12:48
    
I've tried killing the processes but it keeps happening. @ChipBennett the question is about options to debug it and find the error, but I'll edit and list the plugins. Thanks! –  Fernando Briano Nov 3 '11 at 16:58
    
Have you looked in the php error_log? –  v0idless Nov 3 '11 at 17:40
show 1 more comment

2 Answers

up vote 1 down vote accepted

You can't really debug server errors without having really good access to the server itself. This would entail looking at the internal working of this particular host which I'm certain they would not allow nor spend any actual time trying to fix. Move to a better host if they cannot give you more details as to what the problem is or ask for access to the apache and sql logs.

The best you can do really is disable plugins one by one, start with ones that might need lots of cpu like xml sitemaps, or anything running dynamically by a request or action.

Enable slow query logging to pinpoint database problems.

You can also try this plugin, not sure how useful it is, TPC! Memory Usage

share|improve this answer
    
Apart from getting the server logs, running WP Super Cache on debug mode was pretty helpful. –  Fernando Briano Nov 7 '11 at 16:53
add comment

I had the same issues, after some time of not touching the site it suddenly started producing "500 Internal Server Error" on various pages. After a week of pulling my hair it turned out that my "/wp-content/debug.log" (which I enabled a long time ago and then forgot about) was over 128 MB, and therefor could not be written to for some reasons, hence all plugins or features that accessed that file stopped working alltogether. Hence no useful entries in the debug.log, => me confused.

So if you have that enabled and it's large (limit may depend on host settings), try deleting it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.