Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

When I set up my blog i was using the default RSS feed which worked fine. Then I switched it to using FeedBurner using the FeedSmith plugin which also worked without issue.

Now though I want to go back to the default WordPress feed instead. I've removed WordSmith but www.mydomain.com/feed/ still gets redirected to FeedBurner and I can't find a way to stop it.

It's not mentioned in my .htaccess file and the database rewrite_rules only changes that URL to use index.php?feed=rss2 which is the bit that redirects to FeedBurner.

I can use feed=rss or atom to get the wordPress generated feeds but I want the defautl one to use it as well. I've poked around a little in the source to try and trace it but to no avail so far.

Does anyone know where this unwanted redirect might be hiding itself?

As a temporary workaround I'll set the rewrite_rules to redirect it to the RSS 1 feed but would rather it went to the RSS 2 one.

share|improve this question
add comment

1 Answer 1

Visit the Settings - Permalinks page to update the rewrite rules. See if it fixes it.

share|improve this answer
    
I saved the config there but no change. I should have time to check through in the morning and see if I can narrow down exactly where in the code the redirect is happening and trace it back to a setting. –  Dan Brown Nov 2 '11 at 22:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.