Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm running WordPress 3.2.1 on a CentOS box and I'm getting reports from my writers saying they get HTTP 500 errors when they try to update an exciting post.

I've tried the same and have similar problems (although the HTTP 500 only shows in Chrome, Safari and Firefox simply give me a blank window).

I've increased my log level on my httpd install to debug but I still can't find any errors in the logs....

The same box is running another website as well, also using WordPress (same version) and this site is not displaying these symptoms.

All suggestions on how to resolve this are more than welcome!

EDIT: I should also add that I've already tried increasing the PHP Memory in wp-config.php (up the 64MB) but the problem still occurs)

(I'm double-posting this between here and serverfault as I'm not sure wether the problem is related to the server itself or to wordpress...)

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

If the problem is easily reproducible (i.e. you can make it happen again and again by following a set of steps), do this:

  • Step 1: Document the steps required to cause the problem.
  • Step 2: Document all of the plugins you have running
  • Step 3: Deactivate all of your plugins!
  • Step 4: Perform the steps outlined in step 1
  • Step 5: If it's still broken, then you've got a config error somewhere on your server.
  • Step 6: Activate the first plugin in the list from step 2.
  • Step 7: Perform the steps outlined in step 1
  • Step 8: Repeat steps 6-7 with every plugin until the site breaks to figure out what the culprit is.

I had this recently happen on my system, and it turned out to be a name conflict between two plugins I had running on my site.

Also, enable WP_DEBUG in your wp-config.php file ... you might see a better error message, but no promises.

share|improve this answer
    
Thanks for getting me back on track, it was a plugin called "WiziApp". Disabled it and everything is running smooth again. –  Jannemans Oct 17 '11 at 20:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.