WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My theme has a custom post type called 'portfolio'.

I want the url to display 'projects' instead. I've change the rewrite on the register_post_type function to 'projects' but it doesn't change the permalinks...

'rewrite' => 'projects'

How can I fix this?

share|improve this question
up vote 2 down vote accepted

rewrite accepts a boolean or array, try:

'rewrite' => array( 'slug' => 'projects' )

make sure to visit your permalinks settings page to flush rewrites after you make the change.

share|improve this answer
    
Perfect thanks Milo! – fxfuture Oct 12 '11 at 3:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.