Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

This is driving me nuts and I'm hoping someone knows of a way around it.

Say I have a permalink structure of /%postname%/ and I have URLs like www.domain.com/blog/post-name/. So I go about linking and what have you out in the big bad internet.

But, now I decide I want to add a static home page. Say it's a page called "my page". Suddenly WP changes ALL my permalinks to look like www.domain.com/blog/my-page/post-name/! So all the links I have created now point to the wrong place, and my plugin which does some things by retrieving the post_id of the requested url, utterly breaks because that page no longer exists.

Why on earth the WP team would think this is a great idea is beyond me, I simply want to set a specific page to appear when someone visits the root of my blog, not insert that page into the path of all my links.

How can I disable this "feature" or otherwise work around it?

share|improve this question
    
you have something else happening here, WP doesn't do that by default. disable plugins and switch to default theme and test behavior. –  Milo Oct 7 '11 at 3:01
    
Ah crap you're right, I thought it seemed mighty strange... don't know why it snuck up on me but, thanks for the pointers. –  Jonathan van Clute Oct 7 '11 at 3:58
    
try go to admin permalink setting and resave the settings? –  lulalala Oct 7 '11 at 4:09

1 Answer 1

up vote 0 down vote accepted

It sounds like user error to me, or possibly a plug-in. I am leaning towards operator error. WordPress just gives you the vehicle, your the one at the wheel.

The good thing about WordPress is it allows people without the knowledge it takes to build a website a chance to jump right in, sink or swim. It's all a matter of how you set it up. You should always plan ahead and think about how your site will be set up in relation to "Front Page", "Posts" or Blog, categories etc...

If you changed your site from front page displays: a Static Page, then switched it, you might have some "hard-coded" links that are not re-directing. Have you tried visiting the Permalinks page and clicking the update button to see if it fixes it?

share|improve this answer
    
Yeah I'm in mid-plugin development so I've been monkeying with a lot of things involving the permalinks. Didn't see how I could have caused this but I guess I did. Will figure it out. =) –  Jonathan van Clute Oct 7 '11 at 3:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.