WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having troublle with setting my permalink in wordpress site.

I changed the permalink from default to custome : %postname%. In this case my posts are working perfectly, but the pages are not. They generates a error 404 page not found.

I've changed the .htaccess file permission, did everything, but nothing is working.

Any suggestion to solve this?

share|improve this question

There's not much info available by following your link. I suggest the basic troubleshooting steps:

  1. Disable all plug-in's and test the links
  2. Switch to Twenty-Ten or Twenty-Eleven theme
  3. If it' still not working, make sure you have the default .htaccess and nothing more. Here is what it should look like (I had to link to it, this editor was stripping out tags):


Upload that to your root directory and see if it works. If all else fails, switch back to the default permalink structure and see if they work then.

share|improve this answer
Hi, thanks for your reply. I'm not using any plugins (yet), and the .htaccess is set to default wordpress. I have also checked with twenty-ten/twenty-eleven both and the problem persists. I feel pretty sure it has something to with file permissions, but can't find the exact error. Do you know if there is any other file which deals with permalink except .htaccess ? Thanks Again. – Samia Ruponti Sep 24 '11 at 17:22
Your WP-config file could cause the problem, but it's unlikely it's changed (if it has, your have a problem). What happens if you go to the page or post editor and click on the view post button? What is your file structure? Is WordPress in the top level or your server eg;(public_html/wp-admin)? – Jeremy Jared Sep 24 '11 at 20:13
up vote 1 down vote accepted

I figured it out! It was basically a mysql user privilege problem. For security reasons, I had switched off a lot of permissions, so it couldn't write the data. I gave the conflicting permissions and it worked! Thanks to Jeremy for his help!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.