Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Go to this link and click where it says "2 comments" in the sub-title: http://themeforward.com/demo2/2011/01/17/lobortis-tellus-diam/

When the link that brings the user to the comments is clicked it doesn't just scroll users down the page, it brings them to what APPEARS TO BE a separate page (even though it isn't a separate page). This is caused by the extreme margin/padding I am using in #sidebar and #post_content which I am using for equal height columns... http://www.positioniseverything.net/articles/onetruelayout/equalheight Any fixes for this (while still using the equal height columns css)?

THE CSS:

    #container {
        overflow:hidden;
        margin:35px auto
    }
    #sidebar {
        width: 410px;   
        display:block;
        padding-bottom: 32767px;
        margin-bottom: -32767px;
        float:right
    }
    #post_content {
        display:block;
        padding-right:25px;
        padding-bottom: 32767px;
        margin-bottom: -32767px;
        margin-right:25px;
        border-right:1px solid #EEE;
        float:left;
        width: 660px
    }
#commentlist {
    list-style:none;
    width:100%
}

THE LINK:

<a href="#commentlist"><?php comments_number( 'No comments', 'One comment', '% comments' ); ?></a>
share|improve this question
    
that's the same page, there's something strange with your markup or css. if I remove overflow:hidden from #container the content appears again. just view page source, it's all there. –  Milo Sep 22 '11 at 23:07
    
Thanks for pointing this out, I updated the question. –  AndrettiMilas Sep 23 '11 at 2:57

1 Answer 1

up vote 0 down vote accepted

When links are broken into pages (via the settings in WordPress) and the link to bring a user to the comments is clicked it doesn't just scroll users down the page, it brings them to a separate page that is created.

Yes; this is standard WordPress functionality. Paginating comments results in paginated posts, with an appropriate query string parameter for the current comments page.

However, in this case, a separate page isn't being generated, because the post doesn't have enough comments for them to be paginated. Note that the only difference lies in the anchor ( #comments ) being appended to the URL. I concur with @Milo that this is a CSS/markup-related issue.

share|improve this answer
    
Thank you. I'm trying to figure out how to fix this problem while still using the padding/margin for equal height columns as outlined in the link I posted. –  AndrettiMilas Sep 23 '11 at 15:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.