Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have registered a new taxonomy term using the same code on two different sites. On one site (a vanilla install), If I go to my taxonomy term in the admin menu, I see a 'slug' option for the add category screen. On my other site, with all plugins disabled, this slug option does not appear.

Anyone know what might cause this?

Register taxonomy code:

register_taxonomy( 'my_topics', 
array( 'post', 'page' ), 
array( 'hierarchical' => true, 
'label' => 'my Categories', 
'query_var' => 'topics', 
'rewrite' => array('slug' => 'topics')
) ); 
share|improve this question
    
@codecowboy - I hate to ask this but both sites are WordPress v3.x? And where is the drop down you refer to? Your description makes me think you mean this: bit.ly/9tkhDG but it's not a drop down. What's the URL path in the admin where you are having trouble? –  MikeSchinkel Oct 16 '10 at 4:45
    
Yep I did mean that. Sorry - the question title is misleading. I'll change it. –  codecowboy Oct 18 '10 at 8:12
    
From looking at the code, I think this might be related to whether global terms is enabled or not but I can't find the option to switch that on or off either. And yes, both sites are 3.x and are upgrades from WPMU 2.9.2 –  codecowboy Oct 18 '10 at 8:13

1 Answer 1

up vote 1 down vote accepted

The value for global_terms_enabled for multisite is stored in wp_sitemeta

http://wordpress.org/support/topic/plugin-edit-category-slug-wpmu-how-to-make-it-work-with-last-wpmu-30

I switched this to off and the category slug field reappears. If anyone can comment on whether its safe to switch this off, that would be greatly appreciated.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.