Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

My feed links don't work, even after I add this code to functions.php:

          add_theme_support('automatic-feed-links');

When I try go to mysite.com/feed or mysite.com/?feed=rss or any of the links specified in the Codex, I don't get a feed with my content.

In Safari, I get this:

Safari could not update this feed because the source file is no longer available.

In Chrome I get this:

 <channel>
   <title>My Site Name » Page not found</title>
     <atom:link href="http://mysite.com/feed/" rel="self" type="application/rss+xml"/>

etc.

My site used to have a feed through Feedburner, but I wanted to switch to built-in Wordpress feeds. It's very possible I'm misunderstanding something basic fact about how feeds work. What am I doing wrong?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The problem is that the front page is set to a static page. This became clear when I noticed that my feed problem was specific to the front page—feeds for taxonomy archives and post type archives work fine. Only the front page feed was causing trouble.

One way around this is to create a feed template. My starting point is the template here: http://digwp.com/2011/08/custom-feeds/.

Using a feed page template allows the same level of customization you can get from any template file—restrict your feed to certain post types, tags, formats, taxonomy terms, etc.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.