Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

For some reason Total Cache does seem to be caching my pages.

Each time I got to a page, when I view source, the Total Cache comment shows that it regenerated the page for this request.

What worse, it seems to be regenerating the combined/minified css and js files for each request as well! This alone adds another 5sec to the already 4sec the page takes to load.

So I turned on debugging and this is what I am seeing:

W3 Total Cache: Page cache debug info:
Engine: disk: basic
Cache key: w3tc_site.com_1_page_e251273eb74a8ee3f661a7af00915af1
Caching: disabled            //PROBLEM
Reject reason: Requested URI is rejected           //PROBLEM
Status: not cached           //PROBLEM
Creation Time: 0.634s
Header info:
X-Pingback: http://site.com/xmlrpc.php
Content-Type: text/html; charset=UTF-8
X-Powered-By: W3 Total Cache/0.9.2.4

Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/

Minified using disk: basic
Database Caching 6/6 queries in 0.011 seconds using disk: basic
Object Caching 608/613 objects using disk: basic

Served from: site.com @ 2011-09-18 17:47:24

Any ideas what could be going on hear?

Update:

For the record, if it makes a difference, the site is being hosted on IIS 7.5.

share|improve this question
add comment

closed as too localized by toscho Jul 14 '12 at 21:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

Do you have the settings set to an option your hosting provider doesn't allow?

Or maybe you don't have the .htaccess configured correctly to allow the plugin to work as required.

Did you try the default or "automatic" set-up to see if the error is generated?

share|improve this answer
    
Pretty much everything is at default and I haven't manually touched my .htaccess. If it makes a difference I'm using IIS 7 as my web host. –  vdh_ant Sep 19 '11 at 14:28
    
When you set it up did it ask you to make certain permission/re-write changes, or do you recall if you chose to allow the plug-in to make them automatically. –  Jeremy Jared Sep 19 '11 at 14:52
    
No I don't remember it asking me anything like that. Is there a folder that I should check or a way of verifying if the permissions are all setup correctly? I do remember I had trouble, enabling the plugin when I first added it, but it didn't have a specific error. After trying to enable it few time it just worked. –  vdh_ant Sep 19 '11 at 15:12
    
It requires temporary access to the wp-content directory. It changes it from 755 to 705, and must me changed back manually. It also adds a ton of code to the .htaccess file (required to function correctly). If you go to Performance>Install, it will show you an extensive list of files that needed changed. You might check the .htaccess file at least to ensure it's been configured correctly. –  Jeremy Jared Sep 19 '11 at 17:28
    
Does it make a difference that I am running IIS? Under IIS I don't think I have .htaccess. –  vdh_ant Sep 19 '11 at 17:44
show 2 more comments

This appears to be a bug in the latest version of the plugin.

Other users have reported the same issue on the WordPress.org forums - http://wordpress.org/tags/w3-total-cache?forum_id=10

Frederick Townes, the plugin author, has suggested that users try the latest development version of the plugin, which can be downloaded at http://downloads.wordpress.org/plugin/w3-total-cache.zip

share|improve this answer
    
Thanks for the response. One of the question on that is me. Just wanting to verify, are you sure thats the dev/test version? It looks like the same url that is where the released version would be and the version is the same as the released version, 0.9.2.4, which is the one I am having trouble with. –  vdh_ant Sep 21 '11 at 15:06
    
The current release is 0.9.2.4, which can be downloaded at a different url downloads.wordpress.org/plugin/w3-total-cache.0.9.2.4.zip . You can find a complete version list at wordpress.org/extend/plugins/w3-total-cache/download . The development version can be found at the bottom of that page. –  Gary Bairead Sep 22 '11 at 14:51
add comment

I used to use W3 Total Cache plugin on my WordPress Blog (http://bacsoftwareconsulting.com/blog/). My blog is running on Windows Server. I had similar problems to yours. Even though the plugin says that it works on Windows servers, it still have issues. My solution was to discontinue using the W3 Total Cache plugin, and try simpler caching plugins (like Super cache: http://wordpress.org/extend/plugins/wp-super-cache/ or other ones). In windows servers the permission is set by your hosting provider and not like in Linux servers where the user can change the permissions. My advice is don't waste your time trying to run W3 Total cache on Windows servers, or at least use the very basic features of the plugin, or use other plugins. Or find other ways to speed the page load time.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.