Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I previously created a new user role called "Owner" which worked fine, however I decided to delete it afterwards from my functions.php since I found it to not be as useful for my project after all...Odd thing is though, the new custom user role is still showing up in wordpress' dropdown menu where you assign a role to a user in the dashboard.

Any ideas whats going on here? I double checked my functions.php over and over and I deleted the function for sure so I have no ideas whats going on...My guess is its getting cached somehow but clearing the browser out makes no difference.

Best

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

You could try running this once in your functions.php

   $wp_roles = new WP_Roles();
   $wp_roles->remove_role("your_role");
share|improve this answer
add comment

Take look in your database, view your wp_site_options table, find roles, and just see what the heck is going on.

share|improve this answer
add comment

Thanks guys, I couldnt identify the problem in my database so I tried running the removal script and that seemed to do it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.