Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am running Wordpress (3.1.4) with Slickr Flickr (1.3.2). I built a theme on top of thematic (0.9.7.7).

Everything seems to work fine on my local machine and I can render Slickr Flickr galleries in the them templates without issue.

However, when I enable the plug in on our server I get this error:

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/amsfcom/public_html/2011/wp-content/plugins/slickr-flickr/slickr-flickr-oauth.php on line 5

I saw a few questions with answers that seemed to be due to PHP 4 and protected methods. I don't think this is the issue because the server uses PHP version 5.2.9 on Linux. Locally I am using a Mac with PHP version 5.2.15. Could this difference cause the problems?

Is there a way I can start to track down why this is?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

I am pretty sure this is down to your site running PHP4.

I suspect that your server has both PHP5 and PHP4 installed and happens to running PHP4 on this site.

You can verify this by uploading a file version.php to your web root folder containing the following PHP command

<?php echo phpversion(); ?>

Regards

Russell

share|improve this answer
    
Your totally right. In my server dashboard it shows 5, but PHP is using 4. Found a way to do it through the site dashboard, but it looks like I can force it with adding to the htaccess file for the directory. Thanks! –  Chris Butler Sep 14 '11 at 15:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.