Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm using Facebook Comments plugin, I contacted the developer of the plugin and he is saying it's a Facebook app issue. I made sure my application ids matched, but I'm still having the issue. See it here: http://kimpercivalblog.com at the bottom of the posts.

Thanks in advance!!

share|improve this question

migrated from stackoverflow.com Sep 9 '11 at 15:02

This question came from our site for professional and enthusiast programmers.

    
It is not working is not specific enough. I just went to your website and comments are working as far as I see. Although there is some message: warning... Edit: facebook says: The app ID specified within the "fb:app_id" meta tag is not allowed on this domain. You must setup the Connect Base Domains for your app to be a prefix of http://www.kimpercivalblog.com/my-church-dallas-fort-worth-family-photograph/. So you have to change it to match your domain. –  Ivan Ivanić Sep 8 '11 at 20:13

2 Answers 2

You have to setup fb application and config plugin with your app key. Here http://wordpress.org/extend/plugins/facebook-comments-for-wordpress/installation/ is info how.

Here is screenshot: paste key in first input box as in picture.

Fb comments plugin settings

And just a friendly advice, use built in WordPress comments, believe me they work so much better. Fb comments - been there, done that, it just ain't worth it. They are buggy and ugly.

share|improve this answer

The comments are working - but you can see there is an error - in the yellow box below it. My client is requesting the FB comments be installed.

I tried both of those things - I checked the domain settings in my facebook app - it is correct.

I checked the application Id - it is correct and I inputed it into the first box of the plugin.

I even tried CSS to "hide" the box and it did not work!

Any other ideas?? :(

share|improve this answer
    
Check the domain settings in the FB App again, this time with a really strong eye. The presence or lack of "www" matters. The capitalization matters. Basically, your Site URL should be "http:/ /www.kimpercivalblog.com/" and nothing else whatsoever will work. –  Otto Sep 12 '11 at 23:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.