Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Whenever I click on the Author link, I get redirected to the home page. I've set up the author.php page according to the instruction on codex, but still no luck. Does anyone have any other suggestions?

share|improve this question
    
have you tried disabling plugins and switching to default theme? –  Milo Sep 9 '11 at 0:47
    
No - I can't disable my plugins .. they are vital in the website functioning properly. –  MF1 Sep 11 '11 at 21:11
    
the point of disabling plugins and switching themes is to verify that a plugin or theme isn't interfering with your rewrites and redirecting author pages, which is often an issue. if that's the case you can re-enable them one at a time to find out which plugin is to blame, then we can better help you solve your problem. otherwise, we're just guessing. –  Milo Sep 11 '11 at 21:32
    
Ok - When I disable the Yoast SEO plugin, clicking on the author link works! Is it possible to tweak the plugin and have the author page work? –  MF1 Sep 12 '11 at 1:28
1  
under the plugin's settings SEO > Indexation, scroll down to Archive Settings and make sure Disable the author archives isn't checked. –  Milo Sep 12 '11 at 3:02

1 Answer 1

up vote 0 down vote accepted

Under the plugin's settings SEO > Indexation, scroll down to Archive Settings and make sure 'Disable the author archives' isn't checked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.