Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I don't know how but the custom fields box disappeared completely from the New Post Admin page and the screen options as well.

What could cause this ?

share|improve this question

closed as too localized by toscho Sep 6 '12 at 3:10

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I see now that this occurs only with my custom post types, not the regular posts. I tried to deactivate all plugins to no avail, and of course I can't change the theme because I won't be able to use my custom post type. Any idea ? –  Mike Sep 6 '11 at 5:31
    
Are you manually registering your CPT in your themes functions.php file? If so, do you have the setting that looks something like this? 'supports' => array('custom-fields') –  Ben Sep 5 '12 at 22:05
    
Discussion has moved to the support website for ACF support.advancedcustomfields.com/discussion/3076/… –  user20112 Sep 6 '12 at 1:58
add comment

3 Answers 3

changes to WP-admin or possibly upgrading WP admin. Were you using the standard custom fields or a 3rd party plugin? It could also be something from a new theme you have installed? Need a little more detail as to what has changed between the last time it worked correctly and now to answer more concisely.

I had a client ask this recently after upgrading WP and it turned out to be very simple check that 'Custom Field Template' is checked on the 'screen options' drop down menu in the top right of wp-admin.

share|improve this answer
add comment

I'm running into this very problem with the ACF plugin. On my custom posts, the option to show/hide ACF fields (in screen options) is no longer available and the ACF fields are not visible either.

After doing the usual trouble-shooting:

  • turn off all plug-ins
  • activate ACF
  • try making new ACF fields in case old ones are somehow corrupt
  • try reinstalling ACF from scratch
  • turn on ACF debugging and check error log

and discovering nothing, I put my site back together. Then I thought, "I wonder if anything ACF related shows up in the page source HTML?". Sure enough, there was a show/hide ACF checkbox in Screen Options. But it was hidden. This is what Firebug shows:

<label for="acf_input-hide">
<input id="acf_input-hide" class="hide-postbox-tog" type="checkbox" checked="checked" value="acf_input" name="acf_input-hide">
ACF Fields
</label>

which has this style:

#screen-meta label[for="acf_input-hide"] {
    display: none;
}

I have not found a permanent solution yet. But, in FireFox, using Firebug I can disable the display:none and set the ACF visibility as I please while I'm creating/editing a custom post. It's not optimal since the setting doesn't stick. But it's a decent work around.

share|improve this answer
add comment

Having the same problem as dnagirl above with ACF, but I found a temporary solution to this issue (better than using Firebug):

On your web server, open up plugins>advanced-custom-fields>css>input.css. Or in WP go to Plugins and then Edit the Advanced Custom Fields plugin, then click on "advanced-custom-fields/css/input.css" in the right column. Add the following CSS (doesn't matter where):

.acf_postbox {
    display: block !important;
}

Has anyone found a more permanent solution or cause? This fix I posted will probably stop working whenever the plugin is updated, and would have to be done over again.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.