Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Never posted here but since I can't find a solution on my own, let's abuse your kindness!

I'm adding some custom post types through my theme.

The first custom type works like a charm, but as soon as I add the second (and third) one, the apache's error log reports a PHP Warning when trying to do a search action (like the one to search a post to attach a media).

fopen(http://localhost/site/wp-cron.php?doing_wp_cron) [<a href='function.fopen'>function.fopen</a>]: failed to open stream [...] in E:\\www\\site\\wp-includes\\class-http.php on line 876, referer: http://localhost/raw/wp-admin/edit.php

It only happens when I set the 'thumbnail' string into the $args['supports'] array passed to the register_post_type function.

Any help would be much appreciated!

Regards

share|improve this question

1 Answer 1

I had that error pop up a few times recently as well. From what I can tell it's a side effect of the local dev environment.

More reading:

http://wordpress.org/support/topic/wp-30-warning-fopenhttpabccomwp-cronphpdoing_wp_cron

http://core.trac.wordpress.org/ticket/11831

share|improve this answer
    
I've had this as well. From the Trac ticket, adding define('ALTERNATE_WP_CRON', true); to my wp-config.php silenced the warning. –  EAMann Aug 30 '11 at 22:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.