Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

When I try to access my RSS Feed I am getting this error:

error on line 1 at column 35: Unsupported encoding UTF-5

It was working fine just a couple days ago and I'm not sure what I changed if anything to break it. Any Ideas?

share|improve this question
    
What plugins are you running? As @helenhousandi points out below, the RSS feed should be using UTF-8, not UTF-5 ... did you recently install something or change themes? –  EAMann Aug 30 '11 at 18:54
    
the entire site is actually UTF5. And there is a missing quote in the head section of the main site, it states charset=UTF-5" Something is definitely messed up in there –  Rev. Voodoo Aug 30 '11 at 20:02
    
I've gone into the header php that contains the rss function but can't find "UTF-8" or "UTF" what line of code should I be looking for? –  Nick Aug 31 '11 at 0:39

1 Answer 1

up vote 0 down vote accepted

I don't know that this has anything to do with WordPress, but I'm pretty sure it should be UTF-8, not UTF-5. The first line of your RSS feed reads <?xml version="1.0" encoding="UTF-5"?>.

Edit: Try checking your Reading Settings for the Encoding for pages and feeds entry.

share|improve this answer
    
Where do I find the feeds file? I've looked in: wp-feed.php, wp-rss.php, wp-rss2.php, wp-load.php, as well as my header and home files, and this is no mention of "UTF" –  Nick Aug 31 '11 at 1:01
    
I don't think it's a WordPress core file. I'd look at the Reading Settings page in the admin and check the Encoding for pages and feeds entry. This also means I have to eat my words, I guess it does have to do with WordPress :) –  helenhousandi Aug 31 '11 at 3:50
    
You're a genius!! I was right there set to UTF-5, I simply changed it and voilà, RSS is back online :). I know exactly what I did, I some how got into this page and changed it reading it as UTC-8 (timezone) haha and changed it to mine. Thanks again! I'd up vote but not enough rep :( –  Nick Aug 31 '11 at 20:00
    
Hey, so long as it isn't a mystery! Glad it's working for you. –  helenhousandi Aug 31 '11 at 20:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.