Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Hey, there. I just got this site up and going. http://www.paledogstudios.com It works fine except for the fact I can't seem to see past comments (this blog was imported from blogger) or add comments.

I know it's the code not the settings since someone else told me but he didn't help me further.

He said it was probably on the index.php

Help?

share|improve this question
    
do you have a comments.php in your theme folder? if yes, can you pastebin the code? –  sorich87 Oct 7 '10 at 19:44
    
wordpress.pastebin.com/f5ZL99Cs –  nalem Oct 7 '10 at 19:46
    
I think the error is in your index.php file (see my answer). can you pastebin the code of this file? –  sorich87 Oct 7 '10 at 21:13
    
The error is in your theme index.php file. Have you check that out already? –  user8978 Sep 27 '11 at 6:52
add comment

2 Answers 2

up vote 1 down vote accepted

It appears that your posts titles do not link to the single post pages, they link to the archive page. By example, the lastest article "It really is that small" links to "http://www.paledogstudios.com/2010/10/04/".

The error should be in your theme index.php file.

share|improve this answer
    
I changed the permalink to default and now it works! Thank you so much! I don't know if you're up for it but I'm up for drawing you a free art commission for helping me out! If you're interested just message me the info! –  nalem Oct 7 '10 at 21:25
add comment

From the looks of things, you're missing a call to comments_template() in your files. I wouldn't recommend putting this in index.php (that's the file that generates your entire list of blogs ... listing comments there would make your page huge).

What you want to do is add <?php comments_template(); ?> in your single.php file (the template file for Single Posts) before <?php endwhile; ?>.

So an example from the TwentyTen theme:

    </div><!-- #post-## -->

    <div id="nav-below" class="navigation">
        <div class="nav-previous"><?php previous_post_link( '%link', '<span class="meta-nav">' . _x( '&larr;', 'Previous post link', 'twentyten' ) . '</span> %title' ); ?></div>
        <div class="nav-next"><?php next_post_link( '%link', '%title <span class="meta-nav">' . _x( '&rarr;', 'Next post link', 'twentyten' ) . '</span>' ); ?></div>
    </div><!-- #nav-below -->

    <?php comments_template( '', true ); ?>

<?php endwhile; // end of the loop. ?>

You can see they're placing the comment block after contextual navigation but before the loop closes. This is what you'll want to do in your own theme as well.

share|improve this answer
    
I do have that in the code Here's the single.php code wordpress.pastebin.com/CqPRQ837 –  nalem Oct 7 '10 at 19:40
    
In that case, my next guess would be that a plug-in is disabling your comment box. The comments are obviously there (as seen by your footer icon widgets), but these same plug-ins might be disabling the display. Try disabling all of your plug-ins to see if comments show up again. If they do, start turning things back on one-by-one to find the culprit. –  EAMann Oct 7 '10 at 20:20
    
I turned them all off. Still nothing! :( Man this is so weird –  nalem Oct 7 '10 at 20:50
    
Do you have comments enabled in your WordPress settings? Settings >> Discussion >> "Allow people to post comments on new articles" ... –  EAMann Oct 7 '10 at 21:07
    
Yep img40.imageshack.us/img40/3193/helpn.jpg –  nalem Oct 7 '10 at 21:19
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.