Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm having a big problem with Permalinks on our Wordpress installation. It's currently running Ubuntu 10.4 and when i add a page to the site, there are odd things happening:

  1. We get infinite loop and "too many redirect" warnings from different browsers

  2. Other links on the site get redirected to the newly created page For example, after creating a page with the URL of "/promolanding/" when someone clicks on the link to the "/about-us/" page, it redirects them to "/promolanding/"

This works fine on my CentOS development server and only happens on the Ubuntu server.

Permalinks are set to:

/%year%/%monthnum%/%postname%/

and the .htaccess file looks like:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Has anyone ever had this issue? If so, any help would be appreciated.

Thanks!

share|improve this question
    
Is if working fine with default permalink? e.g. p=234 –  Steven Aug 25 '11 at 6:33
    
What version of WordPress are you using, have you clicked save permalinks under settings? Does your server have mod-rewrite installed? –  Wyck Aug 25 '11 at 6:33
    
this has nothing to do with the server version, most likely it is related to apache modules and/or version. –  petermolnar Aug 25 '11 at 8:53
    
@steven, Yes... it works with Default. –  Troy Aug 25 '11 at 14:31
    
@wyck... yes, mod_rewrite is installed and I have Apache 2.2.14 installed. The major concern is that it works for some, but not for others. –  Troy Aug 25 '11 at 14:35
show 1 more comment

2 Answers 2

I've seen this bug before with the redirection plugin. To rule out any theme or plugin issues disable all your plugins switch to the Twentyten or Twentyeleven theme and flush your permalinks. Also make sure there are no other .htaccess files in any of the other WordPress directories or other rules in your vhost file.

I've used Debian / Ubuntu Apache 2.2.14 package on many different servers with no issues.

share|improve this answer
    
Hi Chris, the problem is I don't have any redirection plugin installed... That was the first thing I removed and haven't had it on there since. After I removed it... I did what you had listed above, switched to a different theme and flushed my rules, but it kept happening. I'm thinking it may be something with the settings on the server, but I'm still looking. Thanks! –  Troy Aug 29 '11 at 5:06
add comment
up vote 0 down vote accepted

Ok, thanks everyone for helping out with this, but it looks like the issue was the canonical redirects in wordpress conflicting with the server.

I fixed the problem by adding this to my functions.php file:

remove_filter('template_redirect', 'redirect_canonical'); 

I've never ran into this issue before, but this is the first time I've ever worked with Ubuntu, so it's a learning experience.

Cheers! Troy

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.