Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am creating my first website in wordpress, and I have noticed some strange behavior. The website is really slow on the initial load.

When I open the website after some time of inactivity, let's say an hour, the site loads extremely slow, over 5 sec. After that the website is just fast. Even when I close the browser and open again the website stays fast.

When I switch to another browser, I have the same problem. Initial load is slow, after that the page works as usual.

Anyone know something I could do. I have disabled all plugins and still the same problem, any know what I can do.

Profiling with firebug and Yslow is not really an option, because I can not get good results. I can only test this once every hour.

share|improve this question
    
Who is your webhost? –  Chris_O Aug 23 '11 at 9:11
    
It's a dutch company called versio. –  Saif Bechan Aug 23 '11 at 9:48
    
"Profiling with firebug and Yslow is not really an option, because I can not get good results." Fixing the frontend performance will have a drastic impact on load time. Focus on this. –  Tom Aug 23 '11 at 12:21
    
I know, but the slow load i get only occurs once every hour or so. I think you don't fully understand my problem. I know "Fixing the frontend performance will have a drastic impact on load time", that's a nobrainer. The problem I am facing is hard to spot with those tools. –  Saif Bechan Aug 23 '11 at 12:37
add comment

2 Answers

up vote 0 down vote accepted

Maybe your PHP is running per CGI or FastCGI in a separate process that shuts down after a while of inactivity. Does it change if you register at an uptime monitoring service? A cache plugin like W3 Total Cache may help too.

share|improve this answer
    
Thanks Ill try both. I'm still in development phase so that is why I have not implemented those. I will take a look at those. I will also figure out how cgi and fastcgi are implemented. –  Saif Bechan Aug 23 '11 at 8:09
add comment

One of the typical reasons for such behavior is if you are loading RSS feeds in front-end. Their cache expires and you get very long pause next time, because they need to be fetched over network.

Had you isolated the issue to the hosting? Try to replicate it on local server, it will give you more options for troubleshooting - ultimate one being making full profiler dump (with xdebug for example) and analyzing it.

share|improve this answer
    
I am not loading any rss. I will try to work locally, thank you. –  Saif Bechan Aug 23 '11 at 11:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.