Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am trying to set up Wordpress for a client who uses XO Communications as a host. However, getting Wordpress set up is driving me nuts. I keep getting this error message (wrapping message for clarity):

Warning: main(./wordpress/wp-blog-header.php) 
[function.main]: failed to open stream: 
No such file or directory in /web/wordpress/index.php on line 17

I have manually installed the latest release of WP. The admin area is working fine.

I set my general configurations as:

I modified the index file with this code: require('./wordpress/wp-blog-header.php');

I checked and wp-blog-header exists and is in the wordpress directory.

I have tried reinstalling Wordpress. None of that worked.

I tried downgrading Wordpress: XO offers a one-click installation of an old (2.2.3) version of Wordpress. After downgrading, pages and posts displayed. However, when I upgraded I get the above error message.

Thank you for any help. This is driving me nuts! Jeff

share|improve this question

3 Answers 3

In order to get the latest release of Wordpress working in its own directory on an XO Communications server, I installed the Disable Canonical URLs plugin: 

http://www.mydigitallife.info/2010/01/24/how-to-disable-wordpress-canonical-url-or-permalink-auto-redirect/

share|improve this answer

Did you get clean copy of WordPress for reinstall (like went and downloaded from wordpres.org)? That line should be following (SVN)

require('./wp-blog-header.php');

And it absolutely should not be edited since it is part of WordPress core.

share|improve this answer

what's this for?

require('./wordpress/wp-blog-header.php');

and if you want to include file in wordpress directory which is below your current dir:

require('/wordpress/wp-blog-header.php');
share|improve this answer
    
Thanks for the replies. I deleted my Wordpress installation and loaded a fresh copy, including the original index.php. My new installation is in the root directory with the files of the static site. Things still don't work: all pages and posts go to the home page of the static site. I changed the Permalink structure a few times. When I did a custom structure (/%postname%/) I got a 404 error. Is this an issue with the .htaccess file? Thank you. –  Jeff Tancil Oct 6 '10 at 12:51
    
Thanks for the help. In order to get the latest release of Wordpress working in its own directory on an XO Communications server, I installed the Disable Canonical URLs plugin: mydigitallife.info/2010/01/24/… –  Jeff Tancil Oct 9 '10 at 14:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.