Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I recently updated my site to wordpress 3.2.1 automatically.

Now I tried to manage my sidebar widgets, and noticed I can no longer drag and drop the widgets around. If I look into my browser-console, I notice that the page is unable to load jQuery. Weird: it appends my root-url to the jquery-url, like so:

<script type="text/javascript" src="http://meanderend.dixis.com//ajax.googleapis.com/ajax/libs/jquery/1.6.1/jquery.min.js?ver=3.2.1"></script>

So it is normal that it is not found. How can I fix this. Is there something wrong in my configuration? Or is this a bug? Then it should be general, for everybody, no?

share|improve this question
1  
WordPress doesn't normally load jQuery from Google's CDN, I'd guess you have a plugin or theme interfering here. –  Milo Aug 11 '11 at 14:55
    
In my admin section? Oh wait, a plugin might be possible maybe. I will investigate. –  nathanvda Aug 11 '11 at 19:22

2 Answers 2

up vote 5 down vote accepted

Your theme may be written badly and replace the correct jQuery. Switch to TwentyEleven to check for this. If this doesn’t help, turn off all plugins and re-enable them step by step.

share|improve this answer
    
Amazing. I first deactivated all plugins, without any result. Then I switched the theme back to TwentyEleven, and everything works just fine. Thank you! I would have assumed a theme could not interfere with the admin section ... But of course it could add an extra page there as well. –  nathanvda Aug 11 '11 at 20:06
    
Unfortunately, themes can do most of the things a plugin can do too. Many developers don’t get the difference and put a lot of pure plugin logic into their theme. –  toscho Aug 11 '11 at 20:24

A common cause of this problem (still occurs in 3.3.1 by the way...) is a plugin conflict. We have seen this behavior with both the White Label CMS plugin as well as a combination of Event Espresso and Easy Toolbox.

A couple suggestions have resolved for some ...

  1. place "define('CONCATENATE_SCRIPTS', false);" in the wp-config.php file
  2. reset the plugins folder (logout, rename plugins folder to "plugins.hold", log back in and then change the folder name back to plugins)

However, neither of those are a sure bet -- just less painful than the common plugin conflict issue. Two approaches to tracking down the conflict ... disable one at a time and check the widgets, or disable them all and turn back on one at a time. Either way, helps to have a pair of browsers or at least a pair of browsers tabs in play to minimize the needed clicks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.