Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have created a "custom link" under Menus. enter image description here The problem is that URL in the browser retains the Wordpress URL ( http://blog.tabsonrahm.org ) instead of the linked URL ( http://tabsonrahm.org/about ).

When I click a custom menu link, how do I make it update the URL in the browser to the external link? Thanks.

share|improve this question

1 Answer 1

I believe it's because you're using a frame. The url is changing within the frame itself but it can't reflect it to the base site. You'll have to remove the frame from the site in order to have the url change for you. In fact, I really don't see why you have a frame anyway because if I right click (using FF) and select view only this frame...the site works exactly the same and the URL changes.

Unless I'm missing something, I believe that's your fix. Let me know how it goes.

share|improve this answer
    
jared, thanks a lot for your response. I look through all my Wordpress settings and theme settings. How exactly do I remove the frame? If you go directly to blog.tabsonrahm.org and click on the first blog article link, it can be reproduced. –  Chirag Patel Aug 5 '11 at 2:34
    
The frame is built into the code itself. It's nothing you can remove with a setting in WP. Did you build the site or someone else? Basically the frame is wrapping your whole site and from what I can tell, there's no reason to do that. If you built it, try removing that frame wrapper. If someone else built it, you might ask them if they can make that modification for you. –  igobyjared Aug 18 '11 at 15:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.