Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm on Ubuntu and using LAMP for local dev. I've several WordPress installations for different project and tried to set custom permalinks on all of them, but only default permalink setting ( http://localhost/wpinstalation/?p=123 ) works, other settings are giving 404 error. Any idea how can I fix this?

George

share|improve this question

1 Answer 1

up vote 3 down vote accepted

I had the same problem. It sounds like you don't have rewrites turned on in your installation.

Find your httpd.conf file, find the following line:

#LoadModule rewrite_module modules/mod_rewrite.so

And remove the # at the beginning so it looks like this:

LoadModule rewrite_module modules/mod_rewrite.so

Save and then restart the service. Custom Permalinks should now work. There might be an easier way but I'm not familiar with Linux

share|improve this answer
    
Thanks Manny but mod_rewrite wasn't installed. This answer solved my problem: askubuntu.com/questions/48362/… –  Mamaduka Jul 31 '11 at 7:51
    
oh, thanks! I thought that other answer did the job for you, though. –  Manny Fleurmond Aug 16 '11 at 20:15
    
yes, but from that answer I just got tips for mod_rewrite :) –  Mamaduka Aug 16 '11 at 21:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.